
Using LoggerPro 
 

“Nothing is more terrible than to see ignorance in action.” 

 J. W. Goethe (1749-1832) 

 

 LoggerPro is a general-purpose program for acquiring, graphing and analyzing data. It 

can accept input from a video camera, read a video file or, through the LabPro interface device, 

acquire data from a variety of other sensors. Pictorial data can be reduced to x-y coordinates of 

selected objects, while sensor data is presented in tabular form as a function of time. The 

program will prepare plots of the data, compute statistics like the mean, fit specified curves to a 

data series, and calculate derived quantities. Basic operations will be described here, with more 

detail provided for each exercise. 

 To start LoggerPro you can click on the caliper icon in the main toolbar, or double-click 

on one of the startup files with a .cmbl extension on the desktop. The startup file can configure 

graphs, sensors and other features for a particular experiment, so this is the preferred method.  

 If the program is already running, you can get a clean copy with File > New on the taskbar, 

or load a new startup file with File > Open... When doing so, or when quitting the program, you 

will be prompted to save your previous work. This is usually not necessary but if you do wish to 

save, use File > Save As... and follow the dialog to create a new file so that the original is 

available for other students.  

 

DATA COLLECTION - SENSORS 

 Be sure that the power supply for the LabPro is plugged in, and that it is connected to the 

computer by a USB cable. The sensors needed for a particular exercise will usually already be 

connected to the LabPro interface, but the program needs to know what sensors are connected to 

each port, and how they should be calibrated or actuated. Loading the startup file specified for 

each exercise will provide the proper configuration, a data table with useful columns, and graphs 

as needed. In the unlikely event that the startup file settings are not adequate, the sensor 

configuration can be modified by following Experiment > Set Up Sensors > LabPro I. Changes to 

the data collection rate and other parameters can be made with the window under Experiment > 

Data Collection.... If you do make changes, do not save them under the original file name. 

 Once the program and sensors are configured, you start data collection by clicking the 

Collect button. After a brief pause, the sensors will be read at regular intervals until the Stop 

button is clicked or the time limit is reached. Data will appear in the table and on the graph, if 
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present, as it is obtained. When data collection is complete, you can use the graphing and data 

analysis functions as described below. 

 Motion detector The motion detector, or "sonic ranger", works by sending out short 

pulses of high frequency (ultrasonic) sound and measuring the time between when the pulse is 

emitted and when the first echo is detected. Using the known speed of sound, the time interval is 

converted to a distance interval and then plotted on a computer screen. 

 The software that accompanies the sonic ranger will also estimate the velocity of the 

object as a function of time by computing differences of successive distances. For example, the 

simplest estimate of velocity would be 
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The time interval is necessarily short, so the distances are likely to be nearly equal and their 

difference will be very sensitive to small uncertainties in either value. In order to minimize this 

sort of error the program actually averages over several points: 3, 5, 7, 9, or 15. The algorithm is 

very effective at smoothing the noise but it will also smooth out real changes if they are rapid. 

You will need to take this effect into account, and perhaps change the averaging, as you analyze 

your data. 

 Operationally, there are several factors to be aware of when using the ranger. If an object 

is too close, the echo overlaps the transmitted pulse and cannot be detected. The minimum 

distance our units can measure is about 0.5 m. The ‘beam’ of sound is not sharply defined, but 

diverges in about a 15 cone from the transmitter. If the slider is outside the beam it will not be 

measured, but undesired objects which intrude into the beam may be seen instead of the slider. 

Fortunately aiming is not too critical, and you can locate the center of the cone by looking for 

your own reflection in the metal surface of the diaphragm on the ranger.  

 Force probe The force probe is a plastic box containing a metal beam with a hook. When 

a force is applied to the hook, the beam bends like a spring. Internal sensors measure the 

bending, and report it as a force. Two ranges are available, ±10 N or ±50 N, selectable with a 

switch on the box. The probe only measures forces parallel to the longer axis of the box, not 

perpendicular.  

 Do not exceed a force of 50N, on either scale, to avoid permanent deformation of the 

beam. Try to avoid sudden changes in the applied force, because doing so excites vibrations in 

the force probe which may cause the readings to oscillate for several tenths of a second.  

 Before taking serious data you must calibrate the force probe by applying two known 

forces to it, usually with weights. Set up the probe in the same orientation, horizontal or vertical, 
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as it will be in operation. Then go to Experiment > Calibrate..., and pick the desired sensor from the 

pull-down menu. The Sensor Settings window should open on the Calibrate tab. Verify that the 

probe name is Force-Dual Range with the correct range setting, and then click the Calibrate Now 

button. With nothing connected to the force probe, enter 0 in the box and click Keep. Apply a 

known force to the probe, enter the force in Newtons, and click Keep. The software will perform 

a linear interpolation so that subsequent readings are converted to Newtons for this probe. Exit 

from the calibration routine by clicking the Done button. Repeat the process for the second probe 

if it is in use. 

 

DATA COLLECTION - VIDEO 

 Video is used to measure and analyze the motion of objects, often in two dimensions. 

Two steps are required: A movie of the desired motion is captured in a LoggerPro window, and 

then the movie is analyzed in a separate window.  

 Recording. Be sure the camera is plugged in, turned on to MOVIE mode, and connected to 

the computer. Start LoggerPro and open a recording window by going to Insert > Video Capture.... 

Check that the image is what you want, and then click on the Start Capture button to begin 

recording. Carry out the desired action and then click the Stop Capture button to stop recording. 

Close the recording window by clicking on the dot at the upper left corner.  

 Measuring. The analysis window should now contain your new movie. Movie player 

controls are on the bottom at the left, or you can move along the movie series with the blue slider 

control. Click on the icon with three dots and a triangle at the bottom right to open the analysis 

toolbar. The actual measurement process consists of marking the desired point in each movie 

frame and then marking a known length in one frame to convert picture positions to physical 

dimensions.  

 To mark points, click on the second icon in the vertical row, the one with a dot in crossed 

lines. Position the crosshair cursor at the desired place in the picture and click. The program will 

record the coordinates, put a colored dot at that location, and advance to the next frame. Repeat 

until you have marked all the positions of interest for the motion you are studying.  

 If you need to mark a second set of positions in the movie, click on the icon with two dots 

and lines to pull down the menu. Select Add point series and mark the new points as needed. The 

same pull-down menu lets you add more series, or choose among the series you have already 

created. Caution: For reasons known only to the programmers, each point series is associated 

with a different time base. When plotting, be sure all variables on both axes of your graph are 

from the same point series. 

 To calibrate the scale, move to a frame that shows something of known length which is at 

the same distance from the camera as the object of interest. (The object itself may be used if 
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nothing better is available.) Click on the ruler icon, which is fourth from the top in the analysis 

toolbar. Put the arrow cursor at one end of the known length, then click and drag to the other end. 

Enter the length in the pop-up window. The computer will convert pixel coordinates to real 

distances and place the values in the data table and onto the graph. 

 To translate or rotate the coordinate axes, click on the third icon in the vertical row, the 

one with x-y axes and a small arrow. Position the arrow cursor at the desired origin and click. 

Yellow lines will indicate the new axes, which you can click and drag to adjust. To rotate the 

coordinate system, click on the yellow dot and drag the cursor. The new coordinate axes will be 

used for all the data, whether marked before or after the transformation. 

 

GRAPHING 

 Data from sensors or a movie is usually graphed automatically when appropriate. To 

change the graph scales, click at either end of the x or y axis. Enter the maximum or minimum 

scale value desired and push return. To change the quantity being graphed on either axis, click on 

the axis label and select the desired variable from the menu. 

 You can add additional columns for manual data entry using Data > New Manual Column. 

To calculate a new column from data in previous columns, use Data > New Calculated Column... 

and follow the dialog that pops up. The pull-down menus in the box allow you to pick from the 

available variables and functions to calculate the new column entries.  

 To use LoggerPro as a manual graphing tool, load the startup file Graph.cmbl. This will 

produce a data table with two columns for manual data entry. Type data into the cells of the 

table, and it will be plotted on the adjacent graph. Adjustments can be made as before.  

 

ANALYSIS OF GRAPHED DATA 

 A number of analytic tools can be activated by menu items under Analyze or by clicking 

on icons in the task bar. The analysis will use all the data in the selected graph, unless a subset 

has been selected by clicking and dragging on the graph or data table. The tools most useful for 

this course are  

Examine or x = ? icon: A vertical line cursor will appear in the graph windows. Use the 

mouse to position the cursor as desired, and read the values from the box in each graph. 

To turn off the feature, select the menu entry or icon again.  

Statistics or Stat icon: Computes mean, standard deviation and some other statistics for the 

selected data. 

Integral or curve and area icon: Calculates area under the selected portion of the curve. 
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Linear Fit or R = icon: Fits a straight line to the data and displays slope, intercept and 

correlation coefficient. To obtain error estimates for the fit parameters, double click on 

the display box and check the option in the dialog. 

Curve Fit or f(x) = icon: Fits any of several functions to the data. Choose the desired 

function and follow instructions in the dialog box. 

Most of these are self-explanatory, but curve fitting can become tricky. 

 In comparing a mathematical model with data, we often want to find the parameters that 

lead to the best agreement between some equation and a particular data set. Curve fitting routines 

do this by adjusting the parameters to minimize the sum of the squares of the differences 

between the data and the equation. For simple functions, such as polynomials, the solution can be 

found analytically, and the method is quite reliable. Numerical methods are needed for more 

complex functions, and these do not always produce reasonable results. The best approach is to 

pick parameters that are close to correct, and then let the algorithm do a final refinement. To do 

this in LoggerPro, start the curve fitting procedure and then manually adjust the displayed 

parameter values until the displayed curve follows the data points. Then click on Automatic and 

Try Fit to let the system make final adjustments. In particularly difficult cases you may need to 

repeat this procedure if the algorithm has wandered off to unreasonable choices. 


